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Tutorial 1: Basic Var river simulation 

 The goal of this tutorial is to get yourself familiar with basic TELEMAC-2D usage. You 

will learn how to create a simple mesh in BlueKenue, set up the simulation case scenario in Fudaa-

Prepro and how to run the simulation. Finally results visualisation will be performed with 

BlueKenue and Fudaa Prepro. In the second part you will learn how to use spatially variable bed 

resistance coefficient. 

The following data are required to be used during this exercises: 

 riverOutline.i2s – an ASCII file with outline of the Var river flume (BlueKenue format) 

 DEM_Var_burned.asc – an ASCII file with DEM of lower Var, interpolated on a regular grid with 5 

meters resolution. This DEM has been manually modified, in order to remove bridges. 

 riverFlume.shp – a vector file with polygons, containing different bed types in Var river flume. 

 discharge.liq – text file with discharge data from November 1994 flood 

All spatial layers are prepared using RGF93 / Lambert-93 spatial coordinate system (EPSG code: 

2154). We recommend that you keep this coordinate system for all calculations related to Var 

river. 

Generating simple mesh 

 The first step before running your simulation is to generate the computational mesh. 

Open BlueKenue (BK) and from the top menu select File→ Open, change file format to Line Sets 

(*.i2s,*.i3s) and select riverOutline.i2s and click Open. In order to start new mesh generation, from 

the top menu of BlueKenue window select File→ New→ T3Mesh Generator...  In the dialogue 

window enter 20 as the Default Edge Length and click OK. Drag the riverOutline layer in the Data 

Items manager (left pane of the BK window) and drop it on 2D View, drag  it once again and drop 

on Outline of newT3Mesh. Double click on the newT3Mesh to open its properties. In the 

properties dialogue window click Run to start mesh generation process. In a few seconds BK 

should complete the mesh generation process. After successful competition a new item should 

appear within the newT3Mesh, called New Mesh (Node Type). Drag and drop it to 2D View. Your 

results should resemble the ones from fig. 1. 
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Figure 1 : Results of your first mesh generation in BlueKenue 

 As you generated your first mesh, river bottom elevation data have to be interpolated 

on mesh nodes. From the top menu of BK select File→ Import→ ArcINFO (ASCII) and select 

DEM_Var_burned.asc This file contains DEM of lower Var and will be used as a source of elevation 

data for our mesh. 

 Highlight the New Mesh (Node Type) layer and from the top menu select Tools→ Map 

Object. In the dialog window select the  DEM_Var_burned to be mapped on the mesh and click OK. 

Your mesh should become multicolour, with colour levels representing river bed elevation. 

 You can adjust the colour scale in layer properties. Double click on layer name in the 

Views section of the left pane. In the properties dialog window, go to ColorScale tab. Change the 

interval to 8 meters and click Apply. In the Meta Data tab, set the keywords Name and Title to 

BOTTOM. This will inform TELEMAC, that values associated with mesh nodes are bottom 

elevations. 

 

Figure 2: Mesh after DEM data interpolation. 
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 To create a new file for mesh storage, select from the BK top menu File→ New→ 

Selafin OBJECT… In left pane of the window (Data Items manager), drag and drop your BOTTOM 

layer on the newSelafin file.Highlight the newSelafin file and select from the top menu File → Save 

and save it under the name geo1.slf .  

 In order to be recognized by Fudaa Prepro, the file name has to start with geo.  That’s 

the end of basic mesh generation, you can close Blue Kenue for a moment and proceed to 

simulation case file setup in Fudaa Prepro. 

Setting up your first simulation 

 To start setting up scenario of your first simulation open Fudaa Prepro. The main 

window of Fudaa is called Supervisor. It acts similarly to a typical file and directory explorer (e.g. 

Windows Commander), however it recognizes the files associated with TELEMAC. You will see 

dedicated icons for case files, result files and meshes. 

 

Figure 3: Fudaa Prepro Supervisor window, just after program launch 

 

 Navigate to the folder which contains your newly created mesh file (geo1.slf). Right 

click on the file name and choose Rename from the drop-down menu. Remove the extension .slf 

after the file name. After removing the file extension, your mesh should be recognized by Fudaa as 

a geometry file (fig. 3). 
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Figure 4 : View 2D window in Fudaa Prepro 

 Right click on the mesh file and select Create a Telemac project from the drop-down 

menu. In the dialogue window, make sure that telemac2d dictionary of the latest version is 

selected. The default Steering file name is cas and its’ location is the current directory. You can 

modify the name; however it should start with cas, in order to be recognized by Fudaa. This 

tutorial assumes that you selected English as the language of the case file. Selecting French would 

stick you to French keywords for the rest of your work on this case file. Accept and close the 

dialogue window, by clicking Validate. 

 By default, Fudaa Prepro should open View 2d window now and ask you to initialize 

the boundary conditions. Using magnifier, zoom into mouth of river Var on your mesh. In the 

layers manager (right pane of the window – fig.4, pt. 1) select Boundary nodes layer. Use polygon 

selection tool (fig. 4 - pt. 2) to select boundary nodes at Var mouth. End your selection with double 

click. Selected nodes should remain highlighted. Right click on them and from the drop-down 

menu select Insert liquid nodes… Select liquid nodes with prescribed elevation at 0.0 meters (fig. 

5). This will be the lower boundary of your model. Accept by clicking Validate. A new liquid 

boundary should appear on your mesh. 
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Figure 5: Liquid boundary options 

  Navigate to upper end of your mesh. An inflow boundary should be created 

here. Unfortunately, it’s impossible to use inflow discharge hydrograph and dry domain initial 

condition at the same time (this is a common issue in many modelling systems). A popular way to 

overcome this issue is to create point sources on the boundary nodes, which are intended to be 

inflow boundary and “wet” the initially dry domain. In the Layers manager, highlight Sources 

(subgroup of Weirs / Culverts). Right click on the mesh and from the drop-down menu select Add 

sources. In the dialogue window enter 20 as water discharge of sources. Click on several nodes on 

upper boundary, to add new sources (fig.6). 

 

Figure 6: Adding new sources to mesh 

 After you finished adding new sources, close the View 2D. Open the General 

Parameters window (From the top menu of Fudaa window select Project → General Parameters). 



 

HydroEurope TELEMAC-2D Tutorial 1 7 
 

 

Figure 7: General parameters window 

 The general parameters are organized in a format keyword = value. In the left pane of 

the window you can intuitively filter listed keywords. The modified keywords are highlighted in 

blue, non-modified in black, keywords with errors (usually missing or improper values) are 

highlighted in red. A minimum set of parameters, which need to be set for your first simulation are 

given in the table below: 

Name Value Comment 

LAW OF BOTTOM FRICTION 4 Value indicates, that friction coefficient should be 

interpreted as Manning’s n 

FRICTION COEFFICIENT 0.035 Uniform value of Manning’s n for the whole 

domain 

RESULT FILE res2d Name of the file which will contain results of the 

simulation 

LISTING PRINTOUT PERIOD 30 To limit the amount of the text output, your 

model will print listing information every 30 steps 

GRAPHIC PRINTOUT PERIOD 600 To limit the size of graphic output file, your model 

will save results once per 600 steps 

VARIABLES FOR GRAPHIC  PRINTOUTS B,U,V,H,S Symbols of variables which will be saved in results 

file 

 

 After you set all the necessary parameters click the time step button (watch icon – fig. 
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7.) and set length of your simulation to 24h and time step to one second. Fudaa should 

automatically recalculate number of time steps to 86400.  

 Your first simulation scenario in TELEMAC2D is now ready to be run. Save your case file 

and exit Fudaa Prepro.   

Running the first simulation 

 Before running, transfer your mesh and case files to the computer (or virtual machine), 

that you are planning tu run TELEMAC. Remember to copy not only the two files, but also any 

auxiliary files, which might have been produced by Fudaa. It’s a good practice to create each new 

simulation in a new folder. 

 To run the simulation type into text terminal (or command prompt): 

telemac2d.py case_file 

It happens very often that first simulation fails to run on first attempt. In the last section of this 

document you can find explanations and solutions for the most common TELEMAC2D error 

messages. 

 

Visualizing results of your simulation 

 You can use both Fudaa and BlueKenue to visualize your results. Visualization using 

Fudaa is more rapid-report-oriented (however it’s still feasible to make animations), while 

BlueKenue is supposed to be more interactive. To start viewing your results in Fudaa Prepro, 

double click on the results file res2d in Fudaa Supervisor window. Figure 8 summarizes the most 

popular features which can be used for results visualisation. A very commonly used approach is to 

export the time step of maximum flood inundation to xyz (CSV) file. Such file can be further used 

to produce inundation maps or resilience analysis in GIS software (e.g. QGIS or ArcGIS).  
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Figure 8: TELEMAC2D results visualization in Fudaa Prepro 

 To open the results in BlueKenue, select from the top menu File→ Open, switch file 

type filter to show all files and click on the res2d file. The idea of visualisation in BK is very similar 

to the concept of mesh generation. In the left pan of the window you drag and drop variables from 

data items to 2D or 3D views. You can change colour scale and transparency in properties of each 

variable (right click on the variable name). To enable animation, right click on the variable name 

and select Animate. Worth mentioning are also extraction tools (from the top menu Tools→ 

Extract Surface/TimeSeries/) and animation from a fly path (View→ New Flight Path). Zoom in/out, 

rotation is available under mouse wheel, combined with Ctrl and Shift. Figure 9 summarizes 

visualisation interface of BlueKenue. 
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Figure 9 : TELEMAC2D results visualization in Blue Kenue 

 

Using spatially variable bottom roughness 

 So far you assumed uniform roughness coefficient within the whole riverbed. In order 

to move your model closer to reality we will classify bed roughness into three classes: 

 dense vegetation – Manning’s coefficient equal to 0.05  

 sparse vegetation – Manning’s coefficient equal to 0.035  

 pebbles or sandy material – Manning’s coefficient equal to 0.02  

 

Figure 10: Loading shape file with non-uniform bed roughness in Blue Kenue 

 Open BlueKenue and start from loading your geometry file with the mesh which you 

have generated during previous steps of this tutorial. Load the vector file with areas of different 

roughness riverFlume.shp into BlueKenue (File→Import → ArcView Shape file). By default, the first 

column from Attribute Table is interpreted as a data field. Double click on the layer name to open 

its properties. Go to Data tab and tick the maning column as the one with roughness data (fig.10).
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 On the left pane of the window, right click on the file containing mesh (geo1) and 

select “Add Variable” from the drop-down menu. Select “BOTTOM FRICTION” as the name of the 

new variable and “s/m^(1/3)” as units, 0.02 as the default value. This should create a copy of 

BOTTOM layer, within the geo1 file with a uniform friction assigned. 

 To use the friction values from shape file, highlight the “BOTTOM FRICTION” layer and 

select from the top menu: Tools→ Map Object and select riverFlume from the available objects 

list. As a result – Manning friction coefficient values should be mapped on the grid. To check the 

results -  drag the “BOTTOM FRICTION” layer on the 2D View (fig. 11). 

 

Figure 11: Bottom friction, mapped on the computational mesh 

If you are satisfied with the friction coefficient map, highlight the geometry file and choose from 

the top menu File → Save. 

 In your case file you need to set the name of the file containing friction map, using the 

keyword “FRICTION DATA FILE”. In areas, which are not covered by your spatial manning 

distribution it’s a good practice to set an extremely large value of FRICTION COEFFICIENT (i.e. 

greater than 1), so that you will be sure that your friction map is really in use. The keyword 

GEOMETRY FILE should point to the same file as FRICTION DATA FILE. 

Non-dry initial condition 

 So far, your previous simulation was using point sources with constant discharge, 

located on the upper end of the computational domain. To use discharge as upper boundary 

condition, non-dry initial condition is needed. Last step of your simulation with dry domain can be 

used as an initial condition in a simulation with discharge defined on the upper boundary. Open 

results of your simulation in Fudaa Prepro. Highlight the frame with results and from top sub-
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window menu select Export → Export Data. 

 

Figure 12: Creating initial condition, based on the results of previous simulations 

As variables to be exported select Bathymetry, Free Surface, Water depth (hold Ctrl to select more 

than one variable). As time step, select the last time step, give a name for the file and click Export. 

Close Fuda Prepro post-processing window. 

 In Fudaa Prepro Supervisor window, right click on the mesh file (geo1) and create a 

new case scenario cas2. Follow the same steps as in your previous simulation, with one exception: 

on the upper boundary condition do not create sources. Instead, highlight boundary nodes (Layers 

manager → Boundary conditions  in the right pane of the View 2D window), select nodes of the 

upper boundary. Right click on the highlighted nodes of upper boundary and from the drop-down 

menu select Insert liquid nodes. Choose type: Liquid with prescribed flowrate and insert constant 

flowrate 100m3/s.  

 In layers manager (right pane of the window) select Initial conditions→ IC Nodes. Right 

click and select Enable Initial Conditions from the drop-down menu. In the dialogue window 

choose Initialization from a results file and select the results file which you have just exported 

from your previous results. Click Validate to accept. 

 In general parameters window, make sure, that besides the parameters explained in 

the first part of this tutorial, also the following additional parameters are set: 
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Name Value Comment 

COMPUTATION CONTINUED true Value indicates, that this is a continuation of 

previous simulation 

INITIAL TIME SET TO ZERO true However, we would like our time coordinates to 

start again from the beginning 

PRESCRIBED FLOWRATES 0;100 Flowrates assigned to each boundary 0 – at sea 

boundary will not be considered, 100 – discharge 

at upper boundary condition. 

RESULT FILE res2d_new Name of the results file, in case your simulation is 

in the same folder as previous, make sure you do 

not overwrite its results 

 

 After setting all the parameters, save the case file. Transfer all the simulation files to 

computer with telemac2d and launch the simulation. After completing simulation, make sure you 

understand your results. 

Non-steady boundary condition 

# discharge at La Manda Bridge 

# November 1994 

T       Q(2) 

s       m3/s 

0       300 

3600    320 

7200    320 

10800   300 

Listing 1: Liquid boundary file, representing discharge time series at boundary 2 

 In order to use time series as flood hydrographs,  you need to change your upper 

boundary condition. Open your case file in Fudaa Prepro and launch View 2D. Zoom in to upper 

boundary condition. In layers manager (right pane of the window), highlight Boundary 

Conditions→ Boundaries and right click on the upper boundary. Select Edit the selected boundary 

from the drop-down menu. Change flow rate type to variable in time and click Validate. 

 In general parameters window set the following keyword: 

LIQUID BOUNDARY FILE = discharge.liq 

Make sure that you assigned the discharge to proper boundary (it depends on the order the 

boundaries were created). The liquid boundary file is a self-explaining text file (listing 1.). Finally, 

adjust the simulation length to 48 hours, save the case file and run the simulation. 
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Troubleshooting 

Here are some most common errors, which you may face during your first experiences with 

TELEMAC: 

 file does not exist ( cas.liq ) for key LIQUID BOUNDARIES FILE – due to bug in Fudaa, TELEMAC2D 

is expecting liquid boundaries file, which is not necessary in very simple simulations with steady 

boundary conditions (like your first one). To fix this problem, edit the case file with a text editor 

and comment out or remove the line  LIQUID BOUNDARIES FILE 

 I am looking for an FLOAT but found an inappropriate value set for keyword: VALUES OF THE 

TRACERS AT THE SOURCES – due to bug Fudaa sometimes leaves empty keywords without values. 

This is unacceptable for TELEMAC2D. In such case fix the case file with text editor, either comment 

out the keyword with empty value or assign a value. For example: 

VALUES OF THE TRACERS AT THE SOURCES =;;;; 

should be replaced with: 

VALUES OF THE TRACERS AT THE SOURCES =0;0;0;0;0 

or commented out with a slash ‘/’ at the beginning of the line 

 NO FRICTION LAW IS PRESCRIBED! - bottom friction formula and friction coefficient have to be 

defined in case file 

 DEBIMP: PROBLEM ON BOUNDARY NUMBER      2 

GIVE A VELOCITY PROFILE 

IN THE BOUNDARY CONDITIONS FILE 

OR CHECK THE WATER DEPTHS. - this message is usually a result of super critical flow at the 

boundary, thus water is entering dry domain. It usually indicates that your initial condition was not 

set up properly. 

 

 

 

 


