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1. INTRODUCTION 
In this tutorial, steady and unsteady flow scenarios for the river Rhine and Mehrum 

polder will be investigated using Telemac 2D. In the beginning, a steady-state simulation 

will be modelled to familiarize with the software. Afterwards, a dyke breach scenario will 

be created, and an unsteady simulation will be completed. To complete the simulation, 

BlueKenue, FudaaPrePro, and the command prompt of TELEMAC 2D are operated. 

In this tutorial, a part of the river Rhine is analysed by taking Ruhrort as upstream and 
Wesel as downstream.    

2. INSERTING THE DATA 
For this case study, coordinates with the height of each point along the river have already 

been provided in the project folder. 

From “File → Open”, the coordinate file (Rhein_xyz.xyz) can be found by selecting “All 

Files(*.*)” from the right bottom corner of the “Open” window. 

After adding the data, drag it to the 2D view to visualize the coordinate file (Figure 1). To 

open map legend, right-click on the “Rhein_xyz” 2D view and select “Properties → Colour 

Scale → Show Legend”. The legend can be modified from that window.  

Add the polder data (Rhein_Polder.xyz) by using the same procedure. 

  

 

Figure 1. Rhein River and Mehrum Polder coordinate files 



3. DRAWING RIVER BANKS, OUTLINE OF THE STUDY AREA, AND DYKE 
To draw the channel banks, click “New Open Line” from the toolbar. While determining 

the banks, zoom in to the coordinate file and try to draw the line over the light blue dots 

as much as possible, as shown in Figure 2 (Keep in mind that the dark blue dots indicate 

the flow since they are the deepest points according to the legend. The lines should not 

intersect them). When there is no light blue point in the cross-section, select a point 

where dark blue points end and another colour starts. After finishing drawing a bank, hit 

the “Esc” button on your keyboard and name the drawing as which bank you draw and 

click “OK”. This process should be completed for each bank separately. After saving both 

bank drawings (clicking the floppy disk icon on the toolbar), drag them to the 2D view 
(Figure 3). 

 

Figure 2. Drawing the left bank 

 

Figure 3. Left and right banks along the river 



To define the outline, select “New Closed Line”. Try to include all the coordinate points 

while drawing. While trying to cover protruding dots, avoid drawing sharp corners 

(Figure 4). Instead, enclose them with rectangles as much as possible (Figure 5). Doing 

this will ease the creation of triangular mesh. Click “ESC” to save the outline file after 

surrounding the whole area and drag it to the 2D view (Figure 6). Save the outline 

drawing. 

 

Figure 4. Spikes should be avoided 

 

Figure 5. The better way to enclose protruding points 



 

Figure 6. Outline of the study area 

As the last step, a dyke will be implemented in the model. To do this, select “New Open 

Line” and draw the dyke between polder and river coordinates (Figure 7). After 
completing the drawing, save it as “dyke”.  

 

Figure 7. Drawing the dyke 



The number of points along the dyke line can be seen by right-clicking on “dyke” and 

selecting “Show Attribute Table”. In the current line, there are 27 points which are placed 

irregularly (Figure 8). To have a better mesh, the dyke line should be resampled by right-

clicking on “dyke” and selecting the “Resample” option (Figure 10). In the “Resample 

LineSet” window, select the method as “Equal Distance” and “delta” as 10. It means that 

there will be equally distanced points that have a 10 m distance between them (Figure 

11). After completing the process, there will be a new item named “Resampled dyke”. 

Right-click on it and select “Show Attribute Table” to control if the resampling process 
worked properly (Figure 9). 

 
Figure 8. Attribute table of "dyke" item 

 
Figure 9. Attribute table of "Resampled dyke" item 

 

 
Figure 10. Selecting “Resample” option 

 
Figure 11. Adjusting the resampling 
properties 

 

Suggestions for drawing 

• Carefully draw the lines and do not misclick since undo option does not work for 

removing the mistakenly created points, and the drawing process should begin 

from scratch. 

• Repeat sketching the banks and the outline several times to get used to the 

drawing process. Each repetition will take less time. 

• Do not draw sloppy lines. They might decrease the outcome quality of the 

modelling, and even crash the simulation. 

• While surrounding the most upstream and downstream parts, do not go very close 

to the points. Enclose them a bit wide to prevent mesh anomalies. 

• Do not forget to save the drawings. Try using the same bank, outline and dyke 

drawings for analysing different scenarios in the same study area. 



4. MESH GENERATION 
TELEMAC-2D solves the depth-averaged Navier-Stokes equation utilizing both Finite 

Element (FE) and Finite-Volume (FV) formulations. All of these formulations require that 

a spatial representation of the domain be created using a computational mesh. BlueKenue 

has several tools for mesh generation and editing. Mesh types that BlueKenue can 

generate are unstructured and regular (via T3 Mesh Generator) triangular meshes. 

In this tutorial, along with T3 Mesh Generator, T3 Channel Mesher is also used. To create 

it, click “File → New → T3 Channel Mesher”. From the properties window, adjust Cross 

Channel Node Count as 10 and Along Channel Interval as 50 (Figure 12) and click “OK”. 

Cross Channel Node Count decides the number of lines from the left bank to the right 

bank. Along Channel Interval adjusts the distance between the lines along the channel 
(Figure 13). 

After closing the properties window, a new sub-menu is added to Work Space. For 

creating the channel mesh, drag the left and the right banks under “newT3ChannelMesh” 

accordingly. Then, right-click on “newT3ChannelMesh” and select “Properties”. Click 

“Run” and the channel mesh will be created in seconds (Figure 14). For the sake of 

upcoming steps, it is better to rename the channel mesh file. To do this, open the 

properties of “newT3ChannelMesh”, and select “Mesh → Meta Data”, and rename the file 

as “Channel Mesh”.  

 

 
Figure 12. T3 Channel Mesher properties window 

 

 

Figure 13. Thanks to “Cross Channel Node Count”, there are 10 vertical lines 
from the left bank to the right bank along the blue arrow. Changing the 
"Along Channel Interval" option will affect the distance between to points 
along the orange arrow. The distance is 50 m in this tutorial. 

 



 

Figure 14. Channel Mesh 

To produce mesh for the whole area, click “File → New → T3 Mesh Generator”. From the 

properties window (Figure 15), adjust “Default Edge Length” to 100. “Edge Growth Ratio” 

can remain at 1.2. “Edge Growth Ratio” adjusts the growth rate between each segment, 

and “Default Edge Length” decides the length of an edge. Then click “OK” and close the 
window.  

After closing it, another new sub menu is added to Work Space. For creating the mesh 

along the whole study area, drag the previously drawn outline file to “Outline”, resampled 

dyke to “HardLines”, and Channel Mesh file to “SubMeshes accordingly. Then, right click 

on “newT3Mesh” and select “Properties”. Click “Run” and a new window will pop-up 
(Figure 16).  

 
Figure 15. Property window of T3 Mesh Generator 

 
Figure 16. Confirmation window for running the T3 Mesh 
Generator 

 



Keep in mind that the higher the estimated max node count, the longer the simulation 

time. Of course, it is almost impossible to get the same numbers with Figure 16, since all 

the left-right bank and outline drawings will be unique. After clicking “Yes”, the mesh will 

be completed, and it will look as in Figure 17, after dragging the “New Mesh (NodeType) 

to the 2D View. Keep in mind that there should not be any abrupt triangles in the whole 

mesh as in Figure 18. If it happens, it is better to re-draw the outline (see Section 3 – 
Suggestions for drawing). For the next steps, New Mesh can be renamed as “Whole Mesh”. 

 

Figure 17. Generated mesh in the 2D View 

  
Figure 18. Left: Mesh anomality / Right: Properly created mesh 

  



Inserting bathymetry data into the mesh 
The bathymetry data has to be inserted into the previously created mesh via “File → New 

→ 2D Interpolator”. A new submenu (newInterpolator2D) will be opened in Work Space. 

Drag the coordinate files (Rhein_xyz and Rhein_Polder) into this submenu. To insert the 

bathymetry, select Whole Mesh under the newT3Mesh submenu, then go to “Run→ Map 

Object” and choose “newInterpolator2D” to apply the bathymetry file into the mesh 
(Figure 19). In the Query window, leave the name as “newAttr” and click “OK”. 

 

Figure 19. Mapping the “whole mesh” file with bathymetry data 

Whole Mesh (NodeType) will be automatically converted to Whole Mesh (newAttr), and 

the mesh with bathymetry data will look as in Figure 20. To analyse this map better, a 

legend can be added as described in Section 2. 

 

Figure 20. Mesh with the bathymetry data 



Dyke height adjustment 
After inserting the bathymetry data, the height of the dyke should be checked. To do this, 

select Resampled dyke and map it with Whole_Mesh (newAttr) item as described 

previously. As a result, a new item named “Whole_MeshXSection” will be added to the 
WorkSpace. Drag it into the 1D View (Figure 21).  

 

Figure 21. Dyke height after first mapping 

As it can be seen, the height differs at every point along the dyke. This situation is caused 

by not giving proper “z” values for the dyke in the 2D Interpolator. To solve this problem, 

save “WholeMeshXSection” as a “.i3s” file. Open this file with a text editor (Figure 22). 

Copy the coordinate data and paste them into an Excel sheet. 

 

Figure 22. Content of the ".i3s" file 



If the data is only shown in one column after being pasted to Excel, go to “Data→ Text to 

Columns”. From “Convert Text to Columns Wizard”, select Fixed width, then click “Next” 

and “Finish”, respectively. X, Y and Z data are now separated into three different columns. 

Since the dyke height is 22.6, change all the values under the third column to 22.6. Then, 

for each cell, increase the decimal to 8 (there will be eight digits in the decimal section). 

Finally, create a new text file and paste the values from excel into there (Figure 23). There 
is no need to give any column name here. Save the file as “dyke_coordinate.xyz”. 

 

 

Figure 23. xyz file to give the dyke a proper height 

Now, insert the dyke_coordinate.xyz file into BlueKenue. Create a new T3 Mesh with the 

same steps that are previously described, then name it Dyke_Whole_Mesh. Afterwards, 

create a 2D Interpolator and drag Rheix_xyz, Rhein_Polder and dyke_coordinate files 

under it. To prevent any mistakes, rename this 2D interpolator as Dyke_Interpolator. Map 

Dyke_Whole_Mesh with Dyke_Interpolator bathymetry data. Finally, map the Resampled 

dyke with Dyke_Whole_Mesh(newAttr) and drag it into 1D View (Figure 24). 



 

Figure 24. Corrected height of all points along the dyke 

Ignore the abrupt values at both ends since the error is low in number but looks greater 

due to zoom on the graph. As can be seen in Figure 25, dyke has the same height on every 

point, thanks to the new 2D interpolator. 

 

Figure 25. Comparison graph for dyke height for two meshes 



5. CREATING THE SELAFIN FILE 
 

A selafin and a boundary conditions files are compulsory to run the simulation. To create 

the selafin file, go to “File → New → Selafin Object”. In WorkSpace, a new submenu named 

“newSelafin” will be opened. Right-click on “newSelafin” and select “new Variable”. From 

the “Add New SELAFIN Variable” window, select the properties as it is shown in Figure 

26 (To be able to change the Attribute Name as NewAttr, “Copy Node Values from Source” 

should be selected first). The “BOTTOM” variable helps to define the lowest points in the 

whole area. To check if the process is executed correctly, open 3D View from the Toolbar 

by clicking on “New 3D View” and dragging the BOTTOM file under the “3D View” 

submenu on the WorkSpace (Figure 27). If the 3D View cannot be obtained, please repeat 

the “Add New SELAFIN Variable” process carefully. Finally, save the “newSelafin” file with 
a “.slf” extension. 

 

Figure 26. Adding "Bottom" as a new selafin variable 

 

Figure 27. BOTTOM file in the 3D view 



6. DEFINING THE BOUNDARY CONDITIONS 
As a final step in BlueKenue, boundary conditions should be defined. First, a boundary 

conditions file should be created via “File → New → Boundary Conditions (Conlim)…”. 

From the “Available t3s Objects” window, select “BOTTOM”. A new submenu named 

“BOTTOM_BC” will be created in the WorkSpace. To visualize it, drag “BOTTOM_BC” into 

the 2D view (Figure 28).  

 

Figure 28. BOTTOM_BC file in 2D View 

To determine the upstream boundary condition, zoom in on the upstream part. Select a 

node with a double click, as shown in Figure 29. For determining the boundary, press and 

hold the “Shift” key, and double click to the other node from the opposite side. The 

boundary line’s colour will turn magenta (Figure 30). Right-click on the magenta-

coloured line and click on “Add Boundary Segment”. From the “CONLIM Boundary 

Segment Editor”, select Boundary Code as “Open boundary with prescribed Q” and Tracer 

Code as “Open boundary with free Tracer”. After clicking “OK”, the colour of the upstream 

boundary segment will be blue (Figure 31). More details about these options can be found 
TELEMAC 2D User Manual. 



 
Figure 29. Selecting a node 

 
Figure 30. Determining the upstream boundary segment 

 

Figure 31. Upstream boundary segment with the prescribed Q condition 

Follow the same steps for the downstream boundary and determine the boundary 

segment (Figure 32). Select Boundary Code as “Open boundary with prescribed H” and 

Tracer Code as “Open boundary with free Tracer”. After clicking “OK”, the colour of the 
downstream boundary segment will be green (Figure 33). 

 
Figure 32. Determining the downstream boundary segment 

 
Figure 33. Downstream boundary segment with the prescribed 
H condition 

Finally, from the “BOTTOM_BC” submenu, click on “BOTTOM_BC (LIHBOR) and save it 
with the “.cli” extension.  

!!! Do not close BlueKenue until the end of hotstart file section. 

 



7. CAS FILE 
Creating the CAS file is the last step before running the simulation. CAS file specifies the 

correct parameters that are required to obtain meaningful results. The user must know 

the type of simulation, simulation time and necessary variables. FUDAA Pre-Pro, the 

software available from the TELEMAC-MASCARET ensemble, is used for creating the CAS 

file. Before using the FUDAA Pre-Pro, the output files from BlueKenue should be stored 
in the same folder.  

From the search box inside of the taskbar, search Fudaa Pre-Pro and open it. A new 

supervisor screen will appear on the desktop (Figure 34). 

 

Figure 34. Fudaa Pre-Pro's supervisor window 

Using the leftmost bars, navigate to the location folder in which the geometry (.slf) and 

boundary condition (.cli) files were placed. Afterwards, click “Applications” and select 

“Editor”. From the Editor window, click “Create” (Figure 35). 

 

Figure 35. Editor window 

  



In order to create the file, place the selafin and boundary conditions files respectively 

(Figure 36). For the steering file, open the file explorer by clicking the double dots and in 

write a relevant name for the steering file the “File Name” box, then click save (Figure 37). 

Then, click on the green check mark and ignore the “Cartesian grid is not supported” 
warning (Figure 38).  

 
Figure 36. Inserting necessary files for creating the CAS file 

 
Figure 37. Filling the steering file box 

 

Figure 38. When “No Errors found” is written, click “Continue” 

 

The geometry file with the liquid boundaries will be visible (Figure 39). To give the 

relevant information for the modelling, click on the “Home” icon, which represents the 

“General parameters”, as marked in Figure 39. 

  



 

Figure 39. Visualization of the geometry file with the liquid boundaries 

In the “General parameter” window, “Result File” should be manually filled  as it was 
previously completed for the steering file  (Figure 40). 

 
 

 
Figure 40. Filling the results file box and making the project valid 



From the upper menu of the “General parameters” window, click on “Keywords”. On the 

left side of the window, the “Not modified” option is selected as default. When a 
parameter is modified, it can only be seen if the state is adjusted as “Modified”. 

In the “Mode” submenu, “normal” is the default selection. However, it is better to select 

“Expert” from the “Mode” submenu to see all the parameters that can be altered. 

If nothing is selected from the “Headings” submenu, all the parameters will be listed 

alphabetically. However, to find demanded parameters easily, it is better to use headings. 

Detailed information about the parameters can be found in the Telemac2D User Manual. 

- Boundary Conditions 

By clicking on Add button, insert two options. Adjust the first as 0 and the second as 1 

(Figure 41). 

 

Figure 41. Stage-Discharge curves 

- Equations 

From “Equations”, adjust “Law of Bottom Friction” as 3 (Strickler), “Friction Coefficient” 
as 40 and “Turbulence Model” as 3 (Figure 42). 

 

Figure 42. Modified parameters of the equations heading 

 



- Equations, Boundary Conditions 

In this heading, adjust “Option for Liquid Boundaries” as 1;1 (Figure 43). By default, this 

window will open blank. With the “+ Add” button, add two conditions for both upstream 
and downstream.  

 

Figure 43. Adjustment of the liquid boundaries 

By using the same method, adjust “Prescribed Elevations” as 0.0;0.0, “Prescribed 

Flowrates” as 7410.0;0.0, and “Velocity Profiles” as 5;1. 

- Equations, Initial Conditions 

Here, adjust “Initial Elevation” to 23 and select “Constant Elevation” from the “Initial 

Conditions” box (Figure 44). 

 

Figure 44. Initial conditions 

 

 



- Input – Output, Files 

Steering, geometry, boundary and results files have already been filled in the previous 

steps.  Add the “ratingcurve96_05.txt” file as “Stage-Discharge Curves File”. 

- Input – Output, Graphics and Listing 

Select the “Variables for Graphic Printouts” as shown in Figure 45. These selected 

parameters can be visualized after a successful simulation. Adjust “Listing Printout 

Period” and “Graphic Printout Period” as 100 (unit of these values are second). To have a 

faster simulation with fewer details in the results file, the values of these two parameters 

can be increased. Please note that giving abnormally high values would crash the 

simulation. Finally, mark the Mass-Balance box (Figure 46). 

 

Figure 45. Selected variables for graphic printouts 

 

Figure 46. Modified parameters in Input-Output, Graphics and Listing heading 



- Input – Output, Information 

Give a definitive title to the CAS file from the “Title” box to remember its purpose of it in 

the future works. 

- Numerical Parameters 

Adjust “Time Step” as 10 seconds, “Duration” as 200000 seconds and “Number of Time 

Steps” as 1000.  Since the event is steady, the duration of the simulation along with the 

number of time steps selected for it should be considered as arbitrary. Finally, mark the 

“Continuity Correction” box. 

- Numerical Parameters, Solver 

Open the “Numerical Parameters, Solver” heading. Adjust “Solver” as 2, “Maximum 

Number of Iterations for Solver” as 1000, and “Solver Accuracy as 1. E-3. 

Lastly, save the CAS file by clicking the “Save” button from the top menu. An error 

message which is written in French can occur (Figure 47). Ignore this message and close 

that window. Check the destination folder of the CAS file to control if it is saved 
successfully.  

 

Figure 47. Error message that pops up while saving the CAS file 

Please remember that the created CAS file can be used for simulations for the same study 

area with different boundary conditions or geometry files. Before starting the new 

simulation, open the CAS file with a text reader and change the boundary and geometry 

file names accordingly. Other parameters can also be changed directly via text editor. 

Always keep the CAS file in the same folder as other necessary documents that are stated 
in the CAS file (for example, the Q-H relation file).  

  



8. RUNNING THE SIMULATION AND VISUALIZING THE RESULT FILE 
After successfully creating the CAS file, it is time to run the simulation. To do this, open 

the TELEMAC Command Prompt (the name of this command prompt can differ according 

to the version). In the command prompt, write cd and paste the file destination where the 

CAS file has been saved (Figure 48). After the desired destination is given, type 

telemac2d.py and the full name of the CAS file (in this tutorial it is named 
steering_steady.cas) by leaving one space between them (Figure 48). 

 

Figure 48. Running the simulation 

At the beginning, “Exceeding Maximum Iterations” warning can be seen until the 
simulation reaches the steady state (Figure 49). 

 

Figure 49. Exceeding Maximum Iteration warning 

During the simulation, the values will be updated for each iteration (Figure 50). 

 

Figure 50. Values of an iteration 



From the first line, number of iteration can be understood. Moreover, since the difference 

between the two flux boundaries is low, it can be understood that the model has reached 
a steady state. Of course, this gap can differ a lot in the unsteady simulation. 

Moreover, the value of “Relative Error in Volume at T” can give ideas of the model. Since 

the value is very low, it can be understood that there is no water storage in the model and 
it works without any problem.  

When the simulation ends without any problem, the “My work is done” message occurs 

in the command prompt (Figure 51). In the end screen, total volume lost, duration of 
simulation and name of the result file can be seen. 

 

Figure 51. End screen of the simulation 

 

 

 

 

 



Open the “result.res” file in BlueKenue software to visualize the results. Drag one of the 

parameters into the 2D View for visualization. In Figure 52, “Velocity UV” is animated by 

right-clicking on Velocity UV under the “2D View” and then selecting “Animate”. 

Afterwards, by clicking on the play button, the animation of the simulation can be started, 
and the behaviour of the Velocity UV parameter of each point can be seen (Figure 53). 

 

Figure 52. Animating the Velocity UV parameter 

 

Figure 53. Velocity UV for each point at the end of simulation 

 



A time series graph of any node can be plotted. For this purpose, click on any demanded 

node, then right-click and select “Extract Time Series” (Figure 54). 

A new item will occur under the “Data Items” menu. Open the 1D View, then drag this 
new item under it. The time series plot of the node can be seen (Figure 55). 

 

Figure 54. Creating the Time Series plot of a node 

 

Figure 55. Time Series plot of a node 

As can be seen in Figure 55, velocity increased at the beginning, and there was no critical 

change afterwards. This plot shows that the model has reached a steady state, and this 

result file can be used as a hot start file for the unsteady simulation. 

Feel free to animate other parameters such as Water Depth and Free Surface and make 
other time series plots to understand their behaviour under steady-state conditions. 



9. HOTSTART FILE 
A hotstart file is used to reduce the simulation time required in an unsteady simulation. 

The idea is that a simulation that has already reached a steady state can be used to reduce 

the total simulation time. A good steady-state parametrization hotstart file should include 
the following variables: 

- Velocity in the x-direction 

- Velocity in the y-direction 

- Water depth 

- Free surface 

Without closing BlueKenue after visualizing the results, create a new selafin object as 

described in Section 5. Change the name of this new selafin file to “Rhein-Hotstart”.  

Drag the Velocity UV file into the 2D View and animate it as shown in Section 8. Let the 

animation end, because the end of it will be the last point in which the model has already 

achieved a steady state. After the animation ends, click on the simulation date from the 

animation window and see the number of the last step (it is also automatically written in 

the Calculator Screen of the selected variable). Select Velocity UV file and click “Tools → 

Calculator”. From the calculator screen, select the variable A as “Velocity UV” and select 

“U” (Figure 56). Write the same number to the Start box which is already written in the 

End box (in this simulation, it is 201 but it can differ for other simulations with different 

timestep). Just write “A” to the expression, give a proper name to the file in the name box 

and write the unit (for velocity parameter: M/S). Complete the same procedure for 

Velocity V and compare them visually by dragging files to the 2D view (Figure 57). 

  
Figure 56. Calculator windows for Velocity U and Velocity V 



  
Figure 57. Velocity U (left) and Velocity V (right) files in 2D view 

Now that the velocities are extracted, they need to be mapped accordingly in the new 

selafin object. To do this, right-click the “Rhein-Hotstart” and select “Add Variable”. From 

the “Add New Selafin Variable” window, select Dyke_Whole_Mesh. To create a blank 

mesh, leave the attribute name as NodeType. Select “New Variable Properties” as Velocity 

U and M/S (Figure 58). After that, a new item (Velocity_U) will be created under the 

Rhein-Hotstart submenu. Drag Velocity_U into the 2D view and visualize the blank mesh 

which is completely red (Figure 60). By selecting it, go to “Tools → Map Object” and select 

“Hotstart_Velocity_U” (Figure 59). The velocity U data will be mapped into the blank mesh 
(Figure 61). Complete the same procedure for Velocity V.  

 
Figure 58. Creating blank map for Velocity U variable  

 
Figure 59. Mapping the blank mesh 

 



 
Figure 60. Blank mesh of Velocity U variable 

 
Figure 61. Mapped mesh of Velocity U variable 

 

Complete the same steps for water depth and free surface values (Figure 62 & 63). 

  
Figure 62. Calculating the last frame of Water Depth and Free Surface parameters 

 



  
Figure 63. Water Depth (left) and Free Surface (right) hotstart data 

After creating all four variables, save the Rhein-Hotstart file by clicking on Sloppy Disk 
Icon from the toolbar as “Rhein-Hotstart.slf”. 

  



10. DYKE BREACH AND CONTROL SECTION FILES 
To simulate a dyke breach scenario, a text file needs to be prepared. A sample file is given 
in the project folder named dyke_breach.txt (Figure 64). 

 

Figure 64. Dyke breach text file 

The necessary information should be given in this file.  

- For this simulation, the number of the breach is given as 1. The width of the breach 

is adjusted under the bandwidth title. It is selected as 40 m. However, feel free to 

analyse the effect of different dyke breach widths on the water volume that enters 

to polder.  

- To have an instant breach, the duration of the breaching process is given as 0 

seconds. Yet, a specific duration can be given to have a delayed breach. 

- Option of lateral growth is selected as 2, dyke opening by widening. The bottom 

lowering option is better for simulations of sedimentation and sediment erosion 

processes. 

- Final bottom altitude and control level of breach parameters determine the height 

of the breach. According to the text, dyke breach will happen when the water level 

exceeds 22.6 m and dyke height on the breach area will drop to 22 m. Thus, dyke 

breach height is 0.6 m. Feel free to change this height for further analysis. 

- In Dyke Height Adjustment, points along the dyke were resampled with a 10 m 

gap between each. Thus, nodes along the dyke have a 10 m difference. To have a 

40 m dyke breach width, coordinates of five consecutive nodes should be given. 

The number of points of the polyline should be adjusted to five for this case, and 

coordinates should be written in the “Description of the polyline” part. 

-  Selection of the dyke breach place depends on the analysis. For this project, dyke 

breach place is selected a bit near the upstream part (Figure 65). Feel free to 

change the dyke breach place for further analysis.  

- To select the dyke breach place, drag “resampled dyke” and “Dyke_Whole_Mesh” 

into the 2D view. Select the consecutive nodes that are under the resampled dyke 
line (Figure 65-66-67). 



 

 

Figure 65. Selecting the dyke breach place 

 

  

Figure 66. Zoomed view of dyke breach place 

 

Figure 67. Select the node by clicking the junction point of the triangles 



TELEMAC allows control sections to be included either as node number within the mesh 

or coordinates in the domain. The result information for each section is the instantaneous 

flow rates and cumulated positive and negative flow rates. The section input file 

(control_sections.txt in the project folder) is similar to the dyke breach with specific 
formats depending if the information is included for a point or coordinates (Figure 68). 

 

Figure 68. Control section file 

On the second line, it is written that six different control sections will be given into 

TELEMAC by using the coordinates of the nodes (0 represents this choice. If the number 

of the node will be used, adjust this number to 1). Start and End Point X-Y coordinates of 

the control section lines are given under the relevant control section name. For this work, 

control sections represent upstream, three different sections along the river, 

downstream and the breach place (Figure 69). Middle section lines are user dependent. 

To obtain their coordinates, draw an open line as in Figure 70, then write down the 
coordinates of the both ends, under the relevant title in the text file. 

 
Figure 69. Control sections 

 

 

Figure 70. Determining the X-Y coordinates of both ends 

 



11. ADJUSTING THE CAS FILE FOR UNSTEADY SIMULATION 
For running an unsteady simulation, new requirements will be added as keywords in the 

CAS file via opening it in Fudaa Prepro. This time, a liquid boundary file will be used as 

the upstream boundary condition while the downstream boundary condition is still a Q-
h file. 

Equations 

Adjust “Turbulence Model” as 3: K-EPSILON model. 

Equations, Boundary Conditions 

Adjust prescribed Flowrates as 0;0. 

Equations, Initial Conditions 

Delete the initial conditions because a liquid boundary conditions file will be inserted. If 

it cannot be done from Fudaa PrePro, delete this line from the CAS file by opening it with 

a text editor. 

Input-Output, Files 

Geometry, Stage-Discharge Curve and Boundary Conditions files will remain the same as 

in the steady simulation. However, rename the steering file as “steering_unsteady.cas” 
and the results file as “result_unsteady.res”. In addition, add the following files: 

1) Breaches Data File: “dyke_breach.txt” 

2) Sections Input File: “control_sections.txt” 

3) Liquid Boundaries File: “5430_s1rc88ndhs2c0.liq” 

4) Previous Computation File: “Rhein-Hotstart.slf” 

5) Sections Output File: This file will be created by the user. Give a proper name, for 
example, “control_sections_output.txt”. 

 Input-Output, Graphics and Listing 

Adjust Graphic Printout Period and Listing Printout Period as 720.  

Input-Output, Information 

Change the title to “Unsteady Simulation”. Check the “Computation Continued” box. 

Numerical Parameters 

Adjust “Original Date of Time” as 1995;01;20, since it will be the starting date of data in 
unsteady simulation. 

Put a checkmark on the boxes for “Compatible Computation of Fluxes”, “Initial Time Set 

to Zero” and “Variable Time Step”. 

Select “2: Wave Equation” for “Treatment of The Linear System” and 2 (Flux Control) for 

“Treatment of Negative Depths”. 



Adjust “Desired Courant Number” to 0.7 and increase “Duration” to 2,000,000 seconds 

(around 23 days). Change the “Time Step” to 240, even if it is not relevant since the 
“Variable Time Step” is open. 

Adjust SUPG Option as 2;0;2;2. 

Adjust “Original Date of Time” as 1995;1;20. 

Numerical Parameters, K-Epsilon Model 

Adjust “Maximum Number of Iterations for K and Epsilon” as 100. 

Numerical Parameters, Velocity-Celerity-Hight 

Adjust “Mass-Lumping on H” as 1. 

Physical Parameters 

Mark the box of the “Breach” parameter. 

12. RUNNING THE SIMULATION & RESULTS AND SECTION OUTPUT 

FILE 
The process for running the simulation is similar to the steady simulation. The only 

different thing is the name of the CAS file. Open Telemac prompt window and enter the 
file location. Then, write “telemac2.py steering_unsteady.cas” (without “ ”).  

This simulation will last relatively longer than the steady simulation. When the 

simulation has ended (Figure 71), open the results file in BlueKenue to visualize it. 

Different from the steady simulation, Q values at time t for entered control sections will 

be given for each iteration during the unsteady simulation. 

 

Figure 71. Final screen of the unsteady simulation 



Open the results file in BlueKenue. Drag Velocity UV file into 2D View and animate it. 

Water entrance to the polder during the flood can be seen in Figure 72. The change of 
velocity in the meandering parts upstream can be seen in this Figure, too. 

  
Figure 72. Visualizing the water entrance into the polder 

However, visualization does not provide the necessary information. The amount of water 

that enters the polder should be determined. For this purpose, cross_section_output.txt 

is used. TELEMAC created this document after the specific code given in the CAS file. 

Nonetheless, the interpretation of the numbers is hard due to the way the text file is 

created. The output file gives the time step and the discharge for each control sections at 

a particular time in the same line (Figure 73). To solve this issue, a python script is 

provided in the project folder for rearranging this data as a pandas data frame (Figure 

75). Comparison graphs can be created from here or from Excel by carrying the data into 
it (Figure 76). 

Before running the code, please delete the first two lines from the text file (Figure 

74). 



 

Figure 73. Sections output text file 

 

Figure 74. The text file should look like this before running the python script 

 

Figure 75. Rearranged dataframe 

 

Figure 76. Discharge graph from Excel 



13. FINAL REMARKS 
- To familiarize yourself with the software, repeat the processes from the scratch a 

couple of times. Once the drawings are completed, they can be used for different 

simulations. However, a new mesh is needed for some changes, for example, 

resampling the dyke line because the number of nodes will change. Thus, a new 

hotstart file should be created, too. 

 

- To decrease the simulation time, the dyke line can be interpolated with greater 

values. However, try to avoid implausible numbers. 

 

- While adjusting the duration for the unsteady simulation, take the length of the 

liquid boundary condition file into consideration. If data in the liquid boundary file 

ends before the simulation, the program will crash when it cannot take any data. 

It means the program can run for hours and then crash due to a lack of new data. 

To not waste your time, adjust your duration so that the liquid boundary data 

covers the whole simulation. 

 

- Do not forget to locate all necessary files into the same folder before running the 

simulation. 

 

- In case any problem happens and the simulation does not work, you can look for 

the solution in the TELEMAC-MASCARET forum: 

http://www.opentelemac.org/index.php/assistance/forum5/16-telemac-2d 

 

 


